Site Issue
Resolved
Lasted for 5h

This incident has been resolved.

Tue, Apr 16, 2019, 08:52 PM
5 years ago
Affected components

No components marked as affected

Updates

Resolved

This incident has been resolved.

Tue, Apr 16, 2019, 08:52 PM
3h earlier...

Investigating

Most of our systems have recovered. Some search results may not include the all updates yet.

Tue, Apr 16, 2019, 05:20 PM
1h earlier...

Investigating

Users of Search and Checkout may experience some delays

Tue, Apr 16, 2019, 04:00 PM
20m earlier...

Investigating

We are aware of an issue with site slowness and we are working to fix it now

Tue, Apr 16, 2019, 03:40 PM