Apple Pay is unavailable
Resolved
Lasted for 1h

This incident has been resolved.

Wed, Apr 3, 2019, 06:41 PM
5 years ago
Affected components

No components marked as affected

Updates

Resolved

This incident has been resolved.

Wed, Apr 3, 2019, 06:41 PM
1h earlier...

Investigating

Apple Pay will be unavailable on the Web and Apps for a short period due to maintenance. We'll update again when it is back up and running.

Wed, Apr 3, 2019, 05:09 PM