Etsy search down
Resolved
Lasted for 55m

This incident has been resolved.

Thu, Apr 26, 2018, 07:17 PM
6 years ago
Affected components

No components marked as affected

Updates

Resolved

This incident has been resolved.

Thu, Apr 26, 2018, 07:17 PM

Investigating

Search service has been returned to normal!

Thu, Apr 26, 2018, 07:17 PM
42m earlier...

Investigating

Search functionality has been returned for most users; we are continuing to work on returning full service.

Thu, Apr 26, 2018, 06:35 PM
13m earlier...

Investigating

We are experiencing issues with Etsy's search services. Engineers are aware of the issue and working to resolve.

Thu, Apr 26, 2018, 06:21 PM