Issues with Photos and Digital Downloads
Resolved

(3:37pm ET — <a href="http://www.timeanddate.com/worldclock/fixedtime.html?iso=2017-03-07T20:37:39">See this in your timezone</a>) Photo uploading and digital downloads might not be functional for some users. Our engineers are investigating the issue.

(3:57pm ET — <a href="http://www.timeanddate.com/worldclock/fixedtime.html?iso=2017-03-07T20:57:51">See this in your timezone</a>) Our engineers have identified a technical issue on one of our machines and are working on a fix. We hope to update with further information shortly.

(4:15pm ET — <a href="http://www.timeanddate.com/worldclock/fixedtime.html?iso=2017-03-07T21:15:10">See this in your timezone</a>) Images and downloads should now be functional again. We will continue to monitor the site for any further issues.

RESOLVED at 4:15pm ET — <a href="http://www.timeanddate.com/worldclock/fixedtime.html?iso=2017-03-07T21:15:36">See this in your timezone</a>

Tue, Mar 7, 2017, 12:00 PM
7 years ago
Affected components

No components marked as affected

Updates

Resolved

(3:37pm ET — <a href="http://www.timeanddate.com/worldclock/fixedtime.html?iso=2017-03-07T20:37:39">See this in your timezone</a>) Photo uploading and digital downloads might not be functional for some users. Our engineers are investigating the issue.

(3:57pm ET — <a href="http://www.timeanddate.com/worldclock/fixedtime.html?iso=2017-03-07T20:57:51">See this in your timezone</a>) Our engineers have identified a technical issue on one of our machines and are working on a fix. We hope to update with further information shortly.

(4:15pm ET — <a href="http://www.timeanddate.com/worldclock/fixedtime.html?iso=2017-03-07T21:15:10">See this in your timezone</a>) Images and downloads should now be functional again. We will continue to monitor the site for any further issues.

RESOLVED at 4:15pm ET — <a href="http://www.timeanddate.com/worldclock/fixedtime.html?iso=2017-03-07T21:15:36">See this in your timezone</a>

Tue, Mar 7, 2017, 12:00 PM