Listing Manager Issue
Resolved
Lasted for 18m

The Listing Manager is working correctly again.

Wed, Sep 27, 2023, 08:13 PM
7 months ago
Affected components

No components marked as affected

Updates

Resolved

The Listing Manager is working correctly again.

Wed, Sep 27, 2023, 08:13 PM
18m earlier...

Identified

We've spotted that something has gone wrong with the Listing Manager. We're currently fixing the issue, and will provide an update soon.

Wed, Sep 27, 2023, 07:55 PM