Site Issues
Resolved
Lasted for 37m

This incident has been resolved. If you are still experiencing an issue, please let us know in our Etsy Forums (https://community.etsy.com/t5/Technical-Issues/bd-p/bugs).

Tue, Sep 5, 2023, 06:41 PM
8 months ago
Affected components

No components marked as affected

Updates

Resolved

This incident has been resolved. If you are still experiencing an issue, please let us know in our Etsy Forums (https://community.etsy.com/t5/Technical-Issues/bd-p/bugs).

Tue, Sep 5, 2023, 06:41 PM
25m earlier...

Monitoring

A fix has been implemented and we are monitoring the results.

Tue, Sep 5, 2023, 06:16 PM

Identified

The issue has been identified and a fix is being implemented.

Tue, Sep 5, 2023, 06:11 PM

Investigating

We are currently experiencing an issue and are investigating.

Tue, Sep 5, 2023, 06:10 PM

Investigating

We've spotted that something has gone wrong. We're currently investigating the issue, and will provide an update soon.

Tue, Sep 5, 2023, 06:04 PM