We're experiencing an issue with seller video uploads
Resolved
Lasted for 2h

This incident has been resolved.

Tue, May 30, 2023, 04:19 AM
11 months ago
Affected components

No components marked as affected

Updates

Resolved

This incident has been resolved.

Tue, May 30, 2023, 04:19 AM
2h earlier...

Investigating

We've spotted that something has gone wrong. We're currently investigating the issue, and will provide an update soon.

Tue, May 30, 2023, 01:46 AM