Site slowness
Resolved
Lasted for 16m

We think the impact from the issue is over.

Tue, Mar 28, 2023, 11:42 AM
1 year ago
Affected components

No components marked as affected

Updates

Resolved

We think the impact from the issue is over.

Tue, Mar 28, 2023, 11:42 AM
16m earlier...

Investigating

We've spotted that some operations are taking longer than expected. We're currently investigating the issue, and will provide an update soon.

Tue, Mar 28, 2023, 11:26 AM