Site Issues
Resolved
Lasted for 7h

This incident has been resolved.

Fri, May 6, 2022, 07:17 PM
2 years ago
Affected components

No components marked as affected

Updates

Resolved

This incident has been resolved.

Fri, May 6, 2022, 07:17 PM
4h earlier...

Monitoring

Operations continue to be stable. We are monitoring the situation closely and will close the issue after we feel it is fully resolved. If you are currently experiencing a problem, please visit https://help.etsy.com/

Fri, May 6, 2022, 02:44 PM
1h earlier...

Investigating

Operations continue to be stable. We are still working to mitigate any more disruptions.

Fri, May 6, 2022, 01:18 PM
42m earlier...

Investigating

Operations have stabilized. We are continuing to mitigate the issues.

Fri, May 6, 2022, 12:35 PM
40m earlier...

Investigating

We are experiencing some issues with the site

Fri, May 6, 2022, 11:54 AM