Outbound Emails delayed
Resolved
Lasted for 1h

All outbound emails, including those sent to gmail hosted addresses are functional. We are working on a resolution for resending previously undelivered messages.

Thu, Dec 17, 2020, 12:49 AM
3 years ago
Affected components

No components marked as affected

Updates

Resolved

All outbound emails, including those sent to gmail hosted addresses are functional. We are working on a resolution for resending previously undelivered messages.

Thu, Dec 17, 2020, 12:49 AM
1h earlier...

Investigating

We are experiencing an issue where outbound emails to gmail hosted addresses are being delayed and blocked. We are working on a resolution.

Wed, Dec 16, 2020, 11:35 PM