Investigating issues with Shop Home
Resolved
Lasted for 16m

This incident has been resolved.

Tue, Dec 17, 2019, 07:27 PM
4 years ago
Affected components

No components marked as affected

Updates

Resolved

This incident has been resolved.

Tue, Dec 17, 2019, 07:27 PM
16m earlier...

Investigating

We're looking into sporadic reports of issues loading Shop Home Pages

Tue, Dec 17, 2019, 07:10 PM