Issues
Resolved
Lasted for 9m

This incident has been resolved.

Sun, Jan 20, 2019, 05:20 PM
5 years ago
Affected components

No components marked as affected

Updates

Resolved

This incident has been resolved.

Sun, Jan 20, 2019, 05:20 PM

Investigating

Issues :: We are investigating a search issue affecting the website and the mobile apps

Sun, Jan 20, 2019, 05:14 PM

Investigating

We are investigating issues with search on < http://etsy.com|etsy.com >

Sun, Jan 20, 2019, 05:10 PM