Issue processing or viewing orders
Resolved
Lasted for 21m

This incident has been resolved.

Thu, Aug 23, 2018, 06:02 PM
5 years ago
Affected components

No components marked as affected

Updates

Resolved

This incident has been resolved.

Thu, Aug 23, 2018, 06:02 PM

Investigating

Order processing issue has been resolved, and we will continue to monitor.

Thu, Aug 23, 2018, 06:00 PM
19m earlier...

Investigating

We are investigating issues with processing or viewing orders on Etsy.

Thu, Aug 23, 2018, 05:41 PM