Etsy site issues
Resolved
Lasted for 3m

We have fixed the issue that caused this incident and will continue to monitor.

Thu, Aug 23, 2018, 12:16 PM
5 years ago
Affected components

No components marked as affected

Updates

Resolved

We have fixed the issue that caused this incident and will continue to monitor.

Thu, Aug 23, 2018, 12:16 PM

Investigating

We are experience site issues and are investigating.

Thu, Aug 23, 2018, 12:12 PM