Etsy site issues
Resolved
Lasted for 1h

This incident has been resolved.

Fri, Jun 22, 2018, 02:54 AM
5 years ago
Affected components

No components marked as affected

Updates

Resolved

This incident has been resolved.

Fri, Jun 22, 2018, 02:54 AM
41m earlier...

Investigating

The Etsy marketplace slowness is resolved, we are continuing to monitor intermittent PayPal checkout errors

Fri, Jun 22, 2018, 02:13 AM
36m earlier...

Investigating

We are aware that the Etsy marketplace is having intermittent slowness and we are investigating

Fri, Jun 22, 2018, 01:36 AM