Site Issues
Resolved

(3:39pm ET — <a href="http://www.timeanddate.com/worldclock/fixedtime.html?iso=2017-08-18T19:39:15">See this in your timezone</a>) We are aware that some users are having trouble accessing the site. We are actively investigating.

(3:51pm ET — <a href="http://www.timeanddate.com/worldclock/fixedtime.html?iso=2017-08-18T19:51:11">See this in your timezone</a>) We've identified the cause of the issue and have deployed a fix. We'll continue to monitor.

RESOLVED at 4:00pm ET — <a href="http://www.timeanddate.com/worldclock/fixedtime.html?iso=2017-08-18T20:00:28">See this in your timezone</a>

Fri, Aug 18, 2017, 12:00 PM
6 years ago
Affected components

No components marked as affected

Updates

Resolved

(3:39pm ET — <a href="http://www.timeanddate.com/worldclock/fixedtime.html?iso=2017-08-18T19:39:15">See this in your timezone</a>) We are aware that some users are having trouble accessing the site. We are actively investigating.

(3:51pm ET — <a href="http://www.timeanddate.com/worldclock/fixedtime.html?iso=2017-08-18T19:51:11">See this in your timezone</a>) We've identified the cause of the issue and have deployed a fix. We'll continue to monitor.

RESOLVED at 4:00pm ET — <a href="http://www.timeanddate.com/worldclock/fixedtime.html?iso=2017-08-18T20:00:28">See this in your timezone</a>

Fri, Aug 18, 2017, 12:00 PM