Etsy home page is unavailable
Resolved

(12:38pm ET — <a href="http://www.timeanddate.com/worldclock/fixedtime.html?iso=2017-07-11T16:38:09">See this in your timezone</a>) The Etsy home page is currently unavailable but will be restored shortly.

RESOLVED at 12:43pm ET — <a href="http://www.timeanddate.com/worldclock/fixedtime.html?iso=2017-07-11T16:43:25">See this in your timezone</a>

Tue, Jul 11, 2017, 12:00 PM
6 years ago
Affected components

No components marked as affected

Updates

Resolved

(12:38pm ET — <a href="http://www.timeanddate.com/worldclock/fixedtime.html?iso=2017-07-11T16:38:09">See this in your timezone</a>) The Etsy home page is currently unavailable but will be restored shortly.

RESOLVED at 12:43pm ET — <a href="http://www.timeanddate.com/worldclock/fixedtime.html?iso=2017-07-11T16:43:25">See this in your timezone</a>

Tue, Jul 11, 2017, 12:00 PM