Site Issues
Resolved
Fri, Apr 19, 2024, 11:58 PM
(1 year ago)
·
Affected components

No components marked as affected

Updates

Resolved

This incident has been resolved. If you are still experiencing an issue, please let us know in our Etsy Forums (https://community.etsy.com/t5/Technical-Issues/bd-p/bugs).

Fri, Apr 19, 2024, 11:58 PM

Monitoring

A fix has been implemented and we are monitoring the results.

Fri, Apr 19, 2024, 11:32 PM(25 minutes earlier)

Investigating

We are currently experiencing an issue and are investigating.

Fri, Apr 19, 2024, 11:23 PM