Search errors
Incident Report for Etsy
Resolved
This incident has been resolved.
Posted 7 months ago. Feb 16, 2019 - 03:24 UTC
Investigating
Engineers are investigating errors on Etsy search
Posted 7 months ago. Feb 16, 2019 - 01:40 UTC