Site Issue
Incident Report for Etsy
Resolved
This incident has been resolved.
Posted 5 months ago. Apr 16, 2019 - 20:52 UTC
Update
Most of our systems have recovered. Some search results may not include the all updates yet.
Posted 5 months ago. Apr 16, 2019 - 17:20 UTC
Update
Users of Search and Checkout may experience some delays
Posted 5 months ago. Apr 16, 2019 - 16:00 UTC
Investigating
We are aware of an issue with site slowness and we are working to fix it now
Posted 5 months ago. Apr 16, 2019 - 15:40 UTC
This incident affected: Search and Checkout.