Add to cart issues
Incident Report for Etsy
Resolved
This incident has been resolved.
Posted 5 months ago. Feb 08, 2019 - 18:23 UTC
Update
We have identified the issue and are deploying a fix
Posted 5 months ago. Feb 08, 2019 - 18:18 UTC
Investigating
We are investigating issues adding items to the cart
Posted 5 months ago. Feb 08, 2019 - 18:07 UTC