Search
Incident Report for Etsy
Resolved
This incident has been resolved.
Posted 4 months ago. Mar 07, 2019 - 16:03 UTC
Update
We've resolved the issue and search results are now up to date.
Posted 4 months ago. Mar 07, 2019 - 16:03 UTC
Update
We have identified the issue and are working on a fix for the staleness of search results.
Posted 4 months ago. Mar 07, 2019 - 15:49 UTC
Update
Still investigating - some recent listings additions and updates are missing from search results
Posted 4 months ago. Mar 07, 2019 - 14:36 UTC
Investigating
Some recent listings additions and updates are missing from search results
Posted 4 months ago. Mar 07, 2019 - 11:26 UTC