Search
Incident Report for Etsy
Resolved
This incident has been resolved.
Posted May 25, 2019 - 02:43 UTC
Update
Search :: System is recovering and should be stable soon.
Posted May 25, 2019 - 02:27 UTC
Investigating
Some search results are out of date. We are working on a solution.
Posted May 25, 2019 - 01:25 UTC