Payment Errors
Incident Report for Etsy
Resolved
This incident has been resolved.
Posted 2 months ago. Aug 06, 2019 - 21:18 UTC
Investigating
We are investigating issues with checkouts and seller payment pages
Posted 2 months ago. Aug 06, 2019 - 21:14 UTC