Site Issue
Incident Report for Etsy
Resolved
This incident has been resolved.
Posted 6 months ago. Apr 05, 2019 - 00:09 UTC
Update
: All systems including checkout and sign-in have recovered.
Posted 6 months ago. Apr 05, 2019 - 00:04 UTC
Update
: we've identified the network issue affecting Signing-in and checkout. We are working on a resolution.
Posted 6 months ago. Apr 04, 2019 - 23:38 UTC
Update
Site Issue : We have confirmed the source of the issue that is affecting signin and checkout and are working to address it.
Posted 6 months ago. Apr 04, 2019 - 23:10 UTC
Investigating
We are investigating site issues
Posted 6 months ago. Apr 04, 2019 - 22:53 UTC