Search
Incident Report for Etsy
Resolved
This incident has been resolved.
Posted 4 months ago. May 21, 2019 - 03:25 UTC
Update
Search :: We are continuing to rollout out the fix for this issue
Posted 4 months ago. May 21, 2019 - 02:12 UTC
Investigating
Some search results are out of date. We are rolling out a fix for this.
Posted 4 months ago. May 20, 2019 - 23:37 UTC