Search promotion listings delayed
Incident Report for Etsy
Resolved
This incident has been resolved.
Posted 7 months ago. Nov 23, 2018 - 20:28 UTC
Update
Sales and promotions status is recovering
Posted 7 months ago. Nov 23, 2018 - 19:47 UTC
Investigating
Listings for promotions are delayed and we are working on a solution.
Posted 7 months ago. Nov 23, 2018 - 18:57 UTC