Issues
Incident Report for Etsy
Resolved
This incident has been resolved.
Posted 8 months ago. Jan 20, 2019 - 17:20 UTC
Update
Issues :: We are investigating a search issue affecting the website and the mobile apps
Posted 8 months ago. Jan 20, 2019 - 17:14 UTC
Investigating
We are investigating issues with search on < http://etsy.com|etsy.com >
Posted 8 months ago. Jan 20, 2019 - 17:10 UTC