Search listings delay
Incident Report for Etsy
Resolved
This incident has been resolved.
Posted 8 months ago. Jan 15, 2019 - 17:02 UTC
Investigating
We are currently experiencing delays in updates to listings appearing in search. The issue has been identified and is being fixed.
Posted 8 months ago. Jan 15, 2019 - 16:52 UTC