Search
Incident Report for Etsy
Resolved
This incident has been resolved.
Posted 5 months ago. Apr 15, 2019 - 22:12 UTC
Update
Recovery is in progress.
Posted 5 months ago. Apr 15, 2019 - 18:50 UTC
Investigating
Some search results are out of date
Posted 5 months ago. Apr 15, 2019 - 15:56 UTC