HOMEPAGE FAILURES
Incident Report for Etsy
Resolved
This incident has been resolved.
Posted Feb 19, 2019 - 17:13 UTC
Investigating
We are experiencing intermittent failures on our homepage. A fix is out and we will update shortly when recovered.
Posted Feb 19, 2019 - 17:11 UTC