Search
Incident Report for Etsy
Resolved
This incident has been resolved.
Posted 3 months ago. Jul 31, 2019 - 17:58 UTC
Update
We have a fix for the issue and recovery is underway.
Posted 3 months ago. Jul 31, 2019 - 17:29 UTC
Investigating
Some search results are out of date. We are working on a solution.
Posted 3 months ago. Jul 31, 2019 - 15:40 UTC