Site Errors
Incident Report for Etsy
Resolved
We have identified the issue and it is now resolved.
Posted 2 months ago. Aug 08, 2019 - 19:05 UTC
Investigating
We are investigating elevated site error rates.
Posted 2 months ago. Aug 08, 2019 - 18:59 UTC
This incident affected: Homepage, Search, Cart, Checkout, and Listing.