Site Availability Issues
Incident Report for Etsy
Resolved
This incident has been resolved.
Posted Apr 02, 2019 - 17:11 UTC
Update
The image issue has been resolved. Thank you for your patience.
Posted Apr 02, 2019 - 17:11 UTC
Update
Engineers have identified the problem and are working on fixing it
Posted Apr 02, 2019 - 17:09 UTC
Investigating
We're investigating intermittent issues with images on the home page
Posted Apr 02, 2019 - 17:07 UTC