Search
Incident Report for Etsy
Resolved
This incident has been resolved.
Posted 4 months ago. May 15, 2019 - 20:44 UTC
Investigating
Some search results are out of date. We are working on a solution.
Posted 4 months ago. May 15, 2019 - 19:45 UTC