Search
Incident Report for Etsy
Resolved
This incident has been resolved.
Posted 3 months ago. Jul 14, 2019 - 18:18 UTC
Investigating
Updates to listings in search are delayed. We are currently working on a remediation.
Posted 3 months ago. Jul 14, 2019 - 17:56 UTC