Site Issues
Incident Report for Etsy
Resolved
Site issues have been resolved
Posted Oct 27, 2020 - 18:39 UTC
Identified
investigating an issue with logins
Posted Oct 27, 2020 - 18:33 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 27, 2020 - 18:26 UTC
Update
We are continuing to investigate this issue.
Posted Oct 27, 2020 - 17:48 UTC
Investigating
Currently experiencing issues teams are working to resolve
Posted Oct 27, 2020 - 17:34 UTC
This incident affected: Homepage, Search, Cart, Checkout, and Listing.