intermittent problems loading some pages
Incident Report for Etsy
Resolved
This incident has been resolved.
Posted 5 months ago. Jan 18, 2019 - 18:05 UTC
Update
investigation showed some errors in search which have been fixed
Posted 5 months ago. Jan 18, 2019 - 17:56 UTC
Investigating
Our engineers are investigating reports of a low amount of intermittent errors on some pages.
Posted 5 months ago. Jan 18, 2019 - 17:18 UTC