Site Availability Issues
Incident Report for Etsy
Resolved
This incident has been resolved.
Posted 6 months ago. Mar 20, 2019 - 15:11 UTC
Update
The intermittent availability issue has been resolved. Thank you for your patience.
Posted 6 months ago. Mar 20, 2019 - 15:11 UTC
Update
We've identified the cause of the intermittent availability and engineers are fixing the issue now
Posted 6 months ago. Mar 20, 2019 - 14:59 UTC
Investigating
We're investigating intermittent site availability issues
Posted 6 months ago. Mar 20, 2019 - 14:41 UTC