Search
Incident Report for Etsy
Resolved
This incident has been resolved.
Posted Mar 14, 2019 - 00:24 UTC
Update
Most search results are up-to-date. We're working on fixing the remaining ones.
Posted Mar 13, 2019 - 22:52 UTC
Investigating
We're investigating outdated search results
Posted Mar 13, 2019 - 15:59 UTC