Listing update delays
Incident Report for Etsy
Resolved
This incident has been resolved.
Posted 10 months ago. Nov 24, 2018 - 18:29 UTC
Update
We have identified the problem and are working on getting search up-to-date.
Posted 10 months ago. Nov 24, 2018 - 18:21 UTC
Investigating
We are investigating delays in listing updates appearing in search.
Posted 10 months ago. Nov 24, 2018 - 17:50 UTC