Search
Incident Report for Etsy
Resolved
This incident has been resolved.
Posted May 24, 2019 - 18:11 UTC
Update
Search :: System is recovering and should be stable soon.
Posted May 24, 2019 - 17:51 UTC
Update
Search :: We are continuing to rollout out the fix for this issue.
Posted May 24, 2019 - 16:44 UTC
Update
Search :: We have identified the issue and are rolling out a fix.
Posted May 24, 2019 - 15:42 UTC
Investigating
Some search results are out of date. We are working on a solution.
Posted May 24, 2019 - 14:42 UTC