Apple Pay is unavailable
Incident Report for Etsy
Resolved
This incident has been resolved.
Posted 6 months ago. Apr 03, 2019 - 18:41 UTC
Investigating
Apple Pay will be unavailable on the Web and Apps for a short period due to maintenance. We'll update again when it is back up and running.
Posted 6 months ago. Apr 03, 2019 - 17:09 UTC