Search errors
Incident Report for Etsy
Resolved
This incident has been resolved.
Posted 5 months ago. Apr 22, 2019 - 17:44 UTC
Update
Search is operating normally.
Posted 5 months ago. Apr 22, 2019 - 17:33 UTC
Investigating
Listing search is experiencing errors, we are investigating.
Posted 5 months ago. Apr 22, 2019 - 17:20 UTC